Can't create my group

When I select any of the Group tags, there is no option to create a group so I can add mine. Please advise.

Hi David,

In order to create a group, you need to add a ‘hosting’ skill to your profile. Doing so will change your role to ‘host’ in the system, which gives you this extra function.

I’ve added the hosting skill ‘managing events’ to your profile, so you should now be able to add your group.

You can learn more about how to set your group up here: How to follow, create or customise a group

Shout if you need a hand :slight_smile:


Nope, still no Add group button

Hmm, how strange :thinking:

First let’s make sure you’re seeing the most up to date version of that page. Can you try going to the Groups page and force-refreshing your browser? (see how to do that here)

Does the button appear in the top right after doing that?

Hi James,

when I opened the page again, the button was there this time, however, when filling in my group details, teh Post Code field is grey and won’t accept any input.

Ok, thanks for letting me know. The postcode field is optional and shouldn’t affect the system finding you on map. So if you go ahead and create your group, I’ll look into the issue :slight_smile:

It won’t let me create the group, it now shows that the address cannot be found and substitutes a generic (incorrect) address but still wouldn’t let me enter a post code or save my changes.

Changes now saved but no postcode or correct address

Thanks David. What is the full postal address you’d like to use for the group? I’ll see whether I have more luck

1st Fordingbridge Scouts Hall, The Bartons, Fordingbridge Hampshire, SP6 1AQ. I see the post code field has now auto populated with the incorrect post code.

Just checked with Post Office Post Code Finder, they have:

Fordingbridge Scouts Group, Roundhill, Fordingbridge SP6 1AQ

I’ve amended the address to that but it still won’t let me correct the post code.

I’ve updated the group with that postcode. Does it look right now?

Hi, the postcode is correct thanks, but the address still needs to show the Scouts Hall

Hi David,

Glad we’ve got the postcode sorted. As for the address, it looks like the Scouts Hall hasn’t been added to the mapping tool we use for the site (Open Street Map), which is why the site is having trouble finding it.

Here’s the location on Open Street Map:

I’ve now added it to that map, but it may take a while to update, so if you try again tomorrow, it may work then.

I have a similar problem.
I talked with @neil on e-mail about creating a test group from the Danish repair café network.
Currently I have two problems.

1: There is no button for me to create a new group on the group page. I tried following this guide
2: I can’t figure out how to add a new skill to my profile.

I generally feel quite techie, but right now I’m kind of stuck. :grimacing:

Thanks for the help in advance.

Hi Andreas - I’ve added a hosting skill to your profile now, so you should have permission to create a new group :slight_smile:

As a quick explanation, we’ve built using a few different systems: Discourse for this forum, MediaWiki for the Repair Wiki and a custom Laravel PHP application for everything else. Over the years we’ve been trying to integrate these components, but there are still some areas we haven’t managed yet. Profiles are one of these areas. So technically, everyone has a separate profile for each component. The hosting skills are located in the Laravel component, so if you head to the groups page (for example), then click on your profile pic in the top right and select ‘Your profile’, so should be able to add skills there.

I appreciate it’s confusing! We are planning to revisit how skills function, so this is hopefully a temporary situation.

In the meantime, I’ll update that guide :+1:

1 Like

ah this is useful… was just trying to create one too and may have encountered the same issue. But, not able to. And tried to refresh, add hosting skill, that was not available and group won’t create!

Hi Muntasir, sorry to hear you’re having issues with this. We’ve now fixed the original issue with needing a specific role to create a group; now anyone should be able to.

That means you’ve probably found a new issue. I’ll send you a private message where we can dig a bit deeper.