Fixometer saving edits

resolved

#1

When item already created and go back in to edit it afterwards - gets stuck on ‘saving’


#2

Thanks @Sophia_Flucker - I’ll check into this. Could you let me know the following:

  • Which browser (and version) and operating system you are using?
  • Is this for the 21st July event? (this one - https://restarters.net/party/view/627 ?)
  • Is it for all devices that you try to edit or one in particular?

#3

Hi Neil

Using Chrome Version 68.0.3440.84 (Official Build) (64-bit), Mac OS High Sierra Version 10.13.6.

Yes for 21st July event

Had same issue with a couple of devices.

Thanks

Sophia


#4

Thanks Sophia - one more question - does this happen consistently or is it temperamental? e.g. if you were to go and do it again now would it definitely happen again, or is it only sometimes?


#5

Hi Neil

Just tried it again on another item from another party and it’s happening again. It has never not happened.

Thanks

Sophia


#6

Thanks for this Sophia - sorry to hear it’s still happening.

We’ll look into this, but Neil’s away for a couple of weeks so it may be a short while before we can locate and fix this issue. Bear with us :slight_smile:


#7

This should be resolved now @Sophia_Flucker - let us know if you have any issues. Thanks!


#8

This doesn’t seem to be the case.

I was just having a look at https://restarters.net/party/view/899 and edited the last item (wall clock) just to add the brand name (Habitat). Pressing the button ‘Save device’, it changed to ‘Saving…’ and is stuck in that state. If I refresh the page, the change I made has not been saved.

In case this is of any use, the console shows this error:


#9

Thanks for the report @Panda, we’ll take a look.


#10

Have you taken a look?

I just tried to edit the blanket item on https://restarters.net/party/view/982#devices and after pressing Save. The button shows Saving… and never changes. Reloading the page I lose all my edits (the second time, I made a copy of them). I also attached a picture and this did save fine. BTW I disabled my ad blocker and also userContent.css, but that did not help. The same TypeError as mentioned previously is listed in Console.

So currently I cannot edit devices and hence contribute additional details.

This is using Safari on Mojave.


#11

This should be resolved in our test environment but not yet on live - would you be able to test there? I’ll send you the access details privately.


#12

It’s working in the test environment. What is the issue and when are you going to deploy the fix to the live system?


#13

Great, thank you for verifying.

It’s tied up with a few other developments at the moment which we’re just finishing testing. The whole batch should be pushed today or tomorrow. Generally we aim to deploy bugfixes independently of new features but as there is a deployment scheduled I will keep it included it in that. If there’s any delays due to the other features, I’ll pull the bugfix out and push it independently.

Despite looking like a JS issue on the surface of it this actually turned out to be a permissions bug server-side. At the point of saving the edit the back-end logic was incorrectly checking whether you had the permission to edit.


#14

Thank you for the explanation. There’s no rush for deployment for my own use, but of course it likely affects many others.


#15

This has been pushed to production now - when you get a chance please let me know if you’re able to edit the device on production. Thanks!


#16

I confirm that it is now working. Thank you.


archived #17