Can't invite team members to event

resolved

#1

Just encountered this error when trying to invite volunteers to an event.


#2

Thanks @Stephan_Fortelny

@neil, I wonder whether this is related to: Invite to group not working


#3

Thanks for reporting @Stephan_Fortelny - from what I can see it looks like the problem is that the invited team member already had an account in the old system, but has not yet accessed the new system, and as such has not yet opted in to receiving email notifications from the platform. Does that sound correct? I think that is what is causing the error here.

The invitation has been created successfully, so once your team member has logged in once and completed the registration process, they should be able to navigate to the event within the app (or the direct link here: https://restarters.net/party/view/730) and RSVP.

We need to put a fix in such that you don’t get an error message in this case, but an explanation within the app as to the problem.


#4

I just got the same error, trying to invite people to The Big Fix tomorrow. So did the people who have logged and created an account get an invite? This function is pretty essential!


#5

This issue should be resolved now.

In addition at the point of sending the invites, you see a warning icon next to those who will not receive an email notification.

They will still have a message when then navigate to the event saying they have been invited. In the coming weeks the feature for in-app notifications will be added, so an invited member will see a notification wherever they are in the app that they’ve been invited to an event, even if opted out of email notifications.


#6

A similar / the same error reported by @Ten while trying to send an invite to a Tooting event:

User: Ten
Error: 500
Time: 2018-10-11 22:31:07
URL: https://restarters.net/party/invite
Previous URL: https://restarters.net/party/view/697

Ten, it looks like 3 invites have been sent out now. Did you get this working in the end?


#7

From the logs, looks like this due to a manually typed in name, would that make sense @Ten? Problem with this screen is that it now gives the impression of recognising names and letting you type them in. But it doesn’t - you can only type in email addresses. Perhaps we should separate it out into ‘invite members of your group’ and ‘type in email addresses’? Or any other ideas?

(Aside from that it should trap invalid email addresses and report back to the user, as opposed to crash ofc…)